LACP. Port aggregation

Хай. Сегодня вкратце разберемся, что такое агрегация портов на коммутаторе и для чего она нужна. Допустим есть такая топология:

Два коммутатора L3, ферма серверов подключена к одному, пользователи к другому. Для обеспечения доступности серверов и повышения пропускной способности между коммутаторами можно использовать агрегацию каналов. То есть, мы берем три физических интерфейса на коммутаторе и объединяем их в один как-бы логический интерфейс. При использовании разных протоколов, мы получим разные настройки. В данном случае будем использовать протокол LACP (еще есть проприетарный PAGP и статическое агрегирование). LACP позволяет избежать петель и использовать до 16 каналов (8 standby).
Порты для агрегации должны иметь одинаковые настройки, то есть одинаковый транк-статус, одинаковую скорость, дуплекс и пр. Кроме того они должны быть физически одинаковы, то есть если берем с одной стороны порты FastEthernet, а с другой GigaEthernet, то работать агрегация не будет.
Итак, у нас в топологии мы берем с каждой стороны порты Fa0/1, Fa0/2 и Fa 0/3.
Серверы у нас в VLAN 200 и пользователи в VLAN 100.
Создаем логический интерфейс на обоих коммутаторах:

interface Port-channel 1
description ETHERCHANNEL
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk

Теперь на портах для нашей агрегации производим такие настройки, так же на обеих сторонах:

interface FastEthernet0/1
channel-protocol lacp
channel-group 1 mode active
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
channel-protocol lacp
channel-group 1 mode active
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
channel-protocol lacp
channel-group 1 mode active
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk

Некоторые моменты:
channel-protocol lacp – указывает какой мы используем протокол.
channel-group 1 mode active – указываем номер логического интерфейса и опция ACTIVE означает, что мы включили LACP принудительно, несмотря что у нас там на другой стороне, в то время как настройка PASSIVE – будет означать, что канал заработает, как только придет сообщение протокола LACP. А если указать опцию DESIRABLE, то вместо протокола LACP заработает протокол PAGP.

Проверяем наш агрегированный канал:

Switch A#sh etherchannel summary
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————-

1 Po1(SU) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P)

Видно, что использован протокол LACP. И все три физ. интерфейса объединены в логический.

P.S. даже такие вещи уровня CCNP делаются в обычном Packet tracer. В GNS3 пытался, но там можно только статический etherchannel.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *